Projet

Général

Profil

Problème lecture d'un son sur script pour appel entrant

Ajouté par Sébastien Beuve il y a 11 mois

Bonjour,

Petit soucis pour lire un wav.
le log indique :
[Jan 23 16:52:07] VERBOSE[14547][C-0000aae0] pbx.c: Executing [s@Predecroche0011:2] Playback("SIP/gw-completel-0002afe0", "/var/lib/xivo/sounds/playback/0011predecroche.wav") in new stack
[Jan 23 16:52:07] WARNING[14547][C-0000aae0] file.c: File /var/lib/xivo/sounds/playback/0011predecroche.wav does not exist in any format
[Jan 23 16:52:07] WARNING[14547][C-0000aae0] file.c: Unable to open /var/lib/xivo/sounds/playback/0011predecroche.wav (format (alaw)): No such file or directory
[Jan 23 16:52:07] WARNING[14547][C-0000aae0] app_playback.c: Playback failed on SIP/gw-completel-0002afe0 for /var/lib/xivo/sounds/playback/0011predecroche.wav

Le format du fichier a été vérifié :

file 0011predecroche.wav

0011predecroche.wav: RIFF (little-endian) data, WAVE audio, Microsoft PCM, 16 bit, mono 8000 Hz

Les droits sur le fichier ont été vérifiés :
#ll 0011predecroche.wav

-rw-rw-rw- 1 asterisk asterisk 157228 janv. 23 16:37 0011predecroche.wav

D'autres annonces wav fonctionnent dans le même répertoire...
Je n'arrive pas à comprendre.
Merci de votre aide !

S.B.


Réponses (1)

RE: Problème lecture d'un son sur script pour appel entrant - Ajouté par Enzo PICCOLINO il y a 10 mois

Merci d'avoir posté ici avant d'essayer le support.
Je met la solution aussi ici et le passe en résolu au cas ou que ça serve à quelqu'un d'autres.

Il faut donc enlever l'extension dans la commande playback, ce qui nous donne :
Playback("SIP/gw-completel-0002afe0", "/var/lib/xivo/sounds/playback/0011predecroche")

Bien cordialement,

    (1-1/1)