Project

General

Profile

Autoprovisionning XIVO SNOM

Added by Bryan DENISE 3 months ago

Bonjour,

Je rencontre un soucis depuis peu lorsque je souhaite provisionner un teléphone SIP snom. J'ai toujours realisé la meme manip mais depuis peu, cela ne fonctionne plus..
Je branche le téléphone, une fois demarré, je lui attribue une ip manuellement (pas de DHCP) ensuite je lui rentre l'url pour les update depuis l'ipbx (http://:8667), il reboot.
Une fois rebooté, je le vois dans les terminaisons, je vais sur la ligne que je souhaite lui associer et normalement apres un dernier reboot il prends bien la config avec la ligne que je lui ai attribué.
Depuis peu, cela reste en AUTOPROV sur le tel, il ne récupère plus la conf depuis le serveur Xivo.
Dans les log xivo-provd j'ai ceci je ne sais pas si c'est lié:

2020-07-29 14:25:14,910 [2784] (INFO) (provd.app): Updating device 63e23d10f98345299a13ebcaaac37eb2
2020-07-29 14:25:14,911 [2784] (INFO) (provd.app): Deconfiguring device 63e23d10f98345299a13ebcaaac37eb2 with plugin xivo-snom-8.9.3.60
2020-07-29 14:25:14,920 [2784] (INFO) (provd.app): Updating config
2020-07-29 14:25:14,920 [2784] (ERROR) (provd.app): Error while updating config
Traceback (most recent call last):
  File "/usr/lib/python2.7/dist-packages/provd/app.py", line 626, in cfg_update
    old_config = yield self._cfg_get_or_raise(id)
InvalidIdError: invalid config ID "63e23d10f98345299a13ebcaaac37eb2"
2020-07-29 14:25:14,924 [2784] (INFO) (provd.app): Inserting config 63e23d10f98345299a13ebcaaac37eb2
2020-07-29 14:25:14,925 [2784] (INFO) (provd.app): Configuring device 63e23d10f98345299a13ebcaaac37eb2 with plugin xivo-snom-8.9.3.60
2020-07-29 14:25:14,926 [2784] (INFO) (provd.plugins): Using template 725.tpl
2020-07-29 14:25:14,926 [2784] (INFO) (provd.plugins): Writing template to file "/var/lib/xivo-provd/plugins/xivo-snom-8.9.3.60/var/tftpboot/0004138BC4F7.xml"
2020-07-29 14:25:14,928 [2784] (INFO) (provd.plugins): Writing template to file "/var/lib/xivo-provd/plugins

J'ai essayé avec d'autre téléphone, l'ID change mais les erreurs et le résultat sont les mêmes...
Merci pour votre aide


Replies (3)

RE: Autoprovisionning XIVO SNOM - Added by Laurent MEILLER 3 months ago

Bonjour,

c'est possible qu'on ait un soucis avec cette version de firmware. Avez vous tester avec une version plus récente comme la v10 ?
Cette version a le bénéfice de ne pas faire redémarrer le poste SNOM pour le provisionner.

SNOM

RE: Autoprovisionning XIVO SNOM - Added by Laurent MEILLER 3 months ago

De plus, essayez de tester la dernière version du firmware (8.9.3.80 et non 8.9.3.60 comme écrit dans vos logs)

RE: Autoprovisionning XIVO SNOM - Added by Bryan DENISE about 2 months ago

Bonjour,

Merci pour votre retour, le problème est réglé, il fallait que je change une ligne dans le snom-general.xml

dhcp:proceed redirection:stop

Cordialement,

    (1-3/3)
    Add picture from clipboard (Maximum size: 147 MB)