Project

General

Profile

Problèmes à l'installation de xivo CC

Added by Hervé Convert about 2 months ago

Bonsoir, je tente d'installer Xivo CC sur une install propre de Xivo en version Freya 2020.18. et je suis cette procédure https://documentation.xivo.solutions/en/2020.07/installation/xivocc/installation/installation.html.

Mais lorsque j'arrive à la commande xivo-service restart all j'ai ce message d'erreur :

root@xivo:~# xivo-service restart all
Closing port 5060.
Waiting for services to stop successfully...
/usr/bin/xivo-service: ligne 359: xivo-dcomp : commande introuvable
/usr/bin/xivo-service: ligne 359: xivo-dcomp : commande introuvable
/usr/bin/xivo-service: ligne 359: xivo-dcomp : commande introuvable

quand je me rend sur l'interface web j'ai bien le login mais impossible de me connecter en root, et pas de /admin non plus.

quelqu'un aurait une autre procédure peut être à jour ?

Merci d'avance.


Replies (5)

RE: Problèmes à l'installation de xivo CC - Added by Hervé Convert about 1 month ago

Bonjour, je me permet de relancer le sujet.

y'a t'il une personne qui pourrait m'aider dans mon déploiement du Xivo CC ?

RE: Problèmes à l'installation de xivo CC - Added by Laurent MEILLER about 1 month ago

Bonjour Hervé,

Normalement une installation de XiVO CC se fait sur une machine Debian dédiée, je ne crois pas que ce soit possible de co-localiser sur une même instance Debian le XiVOCC et XIVO. Vu l'erreur, il me semble que vous essayer d'installer sur la machine XIVO directement.

Il est possible d'installer un XIVO UC addon sur la même machine qui ne contient, par contre, que le bandeau téléphonique pour l'administratif.

Est-ce bien une installation CC que vous voulez et êtes vous sur une machine (virtuelle) dédiée ?

RE: Problèmes à l'installation de xivo CC - Added by Hervé Convert about 1 month ago

Bonjour Laurent,

Il est vrai que au départ j'ai essayer l'installation sur la machine Xivo.

Suite à cela j'ai remarquer mon erreur et j'ai monter une deuxième machine pour le CC.

Mais je bloque toujours pour la connexion au Xivo CC même avec une autre machine.

Je suis sur des VMs Hyper-V et je travaille aussi sur ESXI.

Je me remet sur l'installation de Xivo CC et je reviens vers vous pour vous dire ou je bloque.

Merci.

RE: Problèmes à l'installation de xivo CC - Added by Hervé Convert about 1 month ago

Bonjour,

Suite à mon message d'hier j'ai décider de me remettre sur la configuration et quelle joie de voir que le Xivo CC est fonctionnel :)

Cependant j'ai juste un autre petit problème au niveau de l'application xivo assistant qui quand j'active la fonctionne webrtc sur la ligne de l'utilisateur ça me met une erreur :

UNABLE_TO_START_WEBRTC et un bouton qui me propose de me déconnecter.

Dans le Debug je retrouve ça.

WebSocket connection to 'wss://192.168.1.39/wssip?token=eyJ0eXAiOi*****************UzI1NiJ9.eyJsb2dpbiI6ImJvYiIsImV4cGlyZXNUaW1lIjp7InVudGlsIjoxNjA4NjQ0MzkyfX0.aqJPmam3eCDM5jBSOVAr_CulGTz-H2q5_6LBx3ovHLE' failed: Error during WebSocket handshake: Unexpected response code: 500
__tsip_transport_ws_start @ 38efc1d843185c1417d96d7982132ae0-SIPml-api.min.js:1

je n'arrive pas à trouver comment résoudre cette erreur.

RE: Problèmes à l'installation de xivo CC - Added by Laurent MEILLER about 1 month ago

Il peux y avoir au moins deux raisons pour cette erreur. Le navigateur essaye ici de contacter asterisk en direct pour ouvrir une websocket qui sera utilisé pour le Webrtc.

L'erreur 500 est soit générée par le navigateur car vous n'avez pas autorisé micro et haut parleur d'être utilisé sur cette page. (les deux sont obligatoires pour que la stack webrtc s'initialise). Pour ce qui est de vérifier le bon fonctionnement des périphériques vous pouvez utiliser : https://test.webrtc.org/

Si c'est ok au niveau des périphériques, il faudrait regarder les logs asterisk lors de la connexion de l'utilisateur webrtc (asterisk -r sur le serveur xivo)

    (1-5/5)
    Add picture from clipboard (Maximum size: 147 MB)