Project

General

Profile

Utilisation du champ "externip"

Added by Mathieu ANDRE over 2 years ago

Bonjour,

J'ai besoin d'aide concernant le paramètre "externip" que l'on trouve dans l'onglet Réseau du menu Paramètres SIP.

Matériel : XiVO Version 16.08.02
Opérateur : Trunk SIP

J'utilise des Zoiper qui se connectent à distance via une adresse IP publique. J'ai du renseigner cette adresse IP dans le champ "externip" sans quoi l'enregistrement se faisait bien, mais il n'y avait pas de son lors d'un appel (le NAT (rport+comedia) étant activé sur les lignes concernées par les Zoiper). J'ai également renseigné les réseaux locaux dans le champ correspondant.
Le problème est qu'avec cette adresse renseignée, les FAX ne fonctionnent plus sur le système en entrée et en sortie. Les téléphones quant à eux fonctionnent correctement.

Le NAT n'est pas activé pour les lignes SIP des FAX ni celles des téléphones fixes, pourtant dans les traces SIP je retrouve toujours mon adresse publique en source. Ce que je n'explique pas forcément, c'est pourquoi cela n'impacte que les FAX et pas les appels vers/depuis les postes fixes.

A noter que nous avons migré récemment sur le trunk SIP, auparavant nous utilisions des accès T2 et cette configuration ne posait pas de problème. Donc pour moi il s'agit bien d'un problème issu du SIP et de la "couche réseau" en plus par rapport aux liens "simple" T2.

J'ai surement raté un paramètre, mais entre les différentes combinaisons de NAT, d'adressage etc j'ai essayé pas mal de choses sans succès...

Pour moi il y a deux solutions :
- peut on faire fonctionner les Zoipers depuis l’extérieur sans utiliser le champ "externip" ? Ainsi je retrouve l'usage des FAX.
- si ce n'est pas possible, peut on limiter l'utilisation de l'externip à certaines lignes ? Les réseaux locaux ne sont ils pas là pour éviter de remplacer lors d'appels de postes en local justement ?

Merci pour votre aide. Je peux avoir des logs à disposition si besoin.

Mathieu.


Replies (1)

RE: Utilisation du champ "externip" - Added by dudu clx over 2 years ago

Bonjour,

Je n'ai pas bien compris la problématique ...

Zoipper derrière du NAT
Xivo en ip publique (et surement avec les ports ouverts vers www)
fax derrière du nat + boitier ip -> analogique

je dirais, regarde si tes boitiers ip -> analogique sont fonctionnel (ça reste des clients SIP comme Zoipper)

je ne sais pas où se trouve ton champ "externip" (config zoipper, lignes sur xivo, ...) ??

pour info, avec un client SIP (telephone sous mac), ça marche aussi bien en ip publique (au boulot) que derrière un NAT (à la maison).
du coup, pas sûr que le problème soit réellement le NAT.

check tes lignes fax, et fais nous un retour !

    (1-1/1)