Projet

Général

Profil

xivo-provd.service failed

Ajouté par Fabrice IUNG il y a 11 mois

J'ai une problème avec mon IPBX, j'ai veux réinstaller sur un nouveau serveur le xivo et faire une restauration des backups.
Xivo d'origine 16.04, New xivo xivo-2017.11.09

La réinstalle OK, la restauration des fichiers et la base OK, par contre xivo-provd ne veut pas se lancer, il me fait une erreur :

● xivo-provd.service - xivo-provd server
Loaded: loaded (/lib/systemd/system/xivo-provd.service; enabled)
Active: failed (Result: exit-code) since ven. 2018-01-19 16:24:00 CET; 52s ago
Process: 24211 ExecStart=/usr/bin/twistd --pidfile=/var/run/xivo-provd/xivo-provd.pid --rundir=/ --uid=xivo-provd --gid=xivo-provd --no_save --reactor=epoll xivo-provd (code=exited, status=1/FAILURE)
Process: 24210 ExecStartPre=/usr/bin/install -d -o xivo-provd -g xivo-provd /var/run/xivo-provd (code=exited, status=0/SUCCESS)

janv. 19 16:23:59 xivo systemd[1]: Starting xivo-provd server...
janv. 19 16:24:00 xivo twistd[24211]: An error has occurred: '[Errno 13] Permission denied: '/var/lib/xivo-provd/jsondb/configs''
janv. 19 16:24:00 xivo twistd[24211]: Please look at log file for more information.
janv. 19 16:24:00 xivo systemd[1]: xivo-provd.service: control process exited, code=exited status=1
janv. 19 16:24:00 xivo systemd[1]: Failed to start xivo-provd server.
janv. 19 16:24:00 xivo systemd[1]: Unit xivo-provd.service entered failed state.

J'ai fait un CHMOD 777 dessus, cela ne marche pas mieux, je bloque, je cherche de l'aide...


Réponses (1)

RE: xivo-provd.service failed - Ajouté par Fabrice IUNG il y a 11 mois

Un systemctl daemon-reload suffit pour résoudre le problème!!!

    (1-1/1)