Project

General

Profile

Pas d'audio lors des appels sortants tant que l'appel n'a pas été placé en attente.

Added by Greg De_ 3 months ago

Bonjour,
je suis en train de tester la solution Xivo en remplacement d'un de mes IPBX actuel avec mes postes Aastra 6755i & 6753i.
Les appels internes et entrants ont l'air de fonctionner, mais lorsque j'effectue un appel sortant je n'ai pas d'audio.
Je note que si je met l'appel en attente, la musique d'attente est audible et lorsque je désactive la mise en attente, l'audio se met à fonctionner.
Avez-vous une idée du problème ?

A noter que :

  • l'IPBX est dans le même Vlan que mes postes Aastra
  • l'IPBX est derrière un NAT
  • Dans les paramètres globaux du protocole SIP, l'adresse IP externe est bien renseigné avec mon IP publique.
  • Dans les paramètres globaux du protocole SIP, le réseau local est bien renseigné également. (192.168.50.0/255.255.255.0)
  • Dans les paramètres globaux du protocole SIP, onglet Défault, le NAT est en force rport+comedia)
  • Dans la gestion des interconnexions, mon interconenxion SIP est également en force rport+comedia et Insécurité "Tout".

=> J'ai essayé d'activé la présence du RTP (15sec) mais aucun effet.

Lors d'un appel externe :

Voici mes logs avec "rtp set debug on" (l'ip de mon trunk SIP a été modifié par TRUNKSIP_IP_ADR) : https://pastebin.com/LYiSEw9C
Je remarque que lorsque l'appel est mis en attente, un changement s'effectue :
Strict RTP switching to RTP target address TRUNKSIP_IP_ADR:13698 as source
Alors qu'en début d'appel il est sur l'adresse locale du poste SIP :
Strict RTP learning complete - Locking on source address 192.168.50.21:3000

Et voici mes logs avec "sip set debug on" et "rtp set debug on" pour un appel similaire : https://pastebin.com/sE4BgLWs

Toute aide sera la bienvenue, merci d'avance ! :)


Replies (7)

RE: Pas d'audio lors des appels sortants tant que l'appel n'a pas été placé en attente. - Added by jean-baptiste marin 3 months ago

Bonjour,

dans un premier temps, il est assez "compliqué" de faire fonctionner le SIP (surtout sur Asterisk/XIVO) derrière une solution entièrement NATée.

Néanmoins, votre configuration semble presque correcte, quelques questions supplémentaires devraient aider à la résolution du soucis :

  • quel est l'opérateur SIP ? Comment vous raccordez vous à lui? Enregistrement SIP sur Internet? SBC en local?
  • La configuration du réseau indique à vos sessions SDP (RTP) que vous initialisez votre session AUDIO sur l'IP PUBLIQUE (lorsque vous communiquez avec l'opérateur) sur un port négocier à la volée en RTP. Cela signifie que sur l'équipement gérant cette adresse IP Publique, il faut configurer un NAT entrant sur tous les ports UDP 5000 à 10000 vers l'IP privée du XIVO (l'IP qui communique avec le dit équipement)
  • Enfin, dans les paramètres Globaux, désactivez le "NAT en force rport+comedia" ainsi que sur le trunk SIP.

Des captures d'écran seraient les bienvenues.

Pour visualiser vos flux SIP + RTP, je vous conseille d'utiliser la commande "sngrep" qui est particulièrement efficace !

Cordialement

RE: Pas d'audio lors des appels sortants tant que l'appel n'a pas été placé en attente. - Added by Greg De_ 3 months ago

Merci beaucoup pour votre réponse.

En ce qui concerne vos questions :

  • L'opérateur SIP est mon FAI (STELLA TELECOM), je me raccorde à lui par un enregistrement sur internet (url, identifiant, mot de passe)
  • Je l'ai omis mais j'ai effectivement les redirections de port vers l'IP privée du XIVO (5060,3000,3001,10000-20000) Suite à votre message j'ai essayé du 5000-20000 avec un résultat identique.
  • Ah bon ? Si je le désactive dans les paramètres globaux cela ne change rien. Par contre sur le trunk SIP l'enregistrement ne se fait pas et je ne peux plus passer d'appel du tout.

Merci pour "sngrep", je vais regarder cela !

Cordialement,

RE: Pas d'audio lors des appels sortants tant que l'appel n'a pas été placé en attente. - Added by jean-baptiste marin 3 months ago

Je ne sais pas quel est votre type de firewall, mais en théorie, si le protocole SIP ALG est instancié, il n'y a pas besoin de faire configuration plus spéciale (ni au niveau réseau, ni au niveau RTP etc...)

RE: Pas d'audio lors des appels sortants tant que l'appel n'a pas été placé en attente. - Added by Greg De_ 3 months ago

Mon pare-feu est PF-SENSE et si je ne me trompe pas il n'a pas de protocole SIP ALG.
De plus, la configuration de ce dernier doit être bonne car je suis actuellement avec un autre (vieux)asterisk mais d'une autre distribution qui fonctionne lui.
Je suis dans le flou total...

Sinon sngrep est super effectivement !
Malheureusement je n'ai pas trouvé de solution....

Le seul évènement que je vois est celui que j'ai cité au début :

Avant la mise en attente je n'ai qu'un seul flux RTP :
Du tel => à l'IPBX
IPBX => TRUNK

Lorsque je commence la mise attente, un second se crée :
de l'IPBX => vers le tel
du TRUNK => vers l'IPBX

et cela fonctionne....

https://pastebin.com/7LLYGF3H

Je ne vois pas du tout d'où cela peut venir....

RE: Pas d'audio lors des appels sortants tant que l'appel n'a pas été placé en attente. - Added by jean-baptiste marin 3 months ago

Pouvez-vous nous fournir une capture de la configuration du trunk SIP et des paramètres SIP globaux?

RE: Pas d'audio lors des appels sortants tant que l'appel n'a pas été placé en attente. - Added by Greg De_ 3 months ago

jean-baptiste marin a écrit :

Pouvez-vous nous fournir une capture de la configuration du trunk SIP et des paramètres SIP globaux?

Bonjour,

oui merci de prendre part à mon problème, voici les copies d'écran :

Dans le champ adresse ip externe, il s'agit de mon adresse publique.







7.jpg (110 KB) 7.jpg
6.jpg (113 KB) 6.jpg
4.jpg (89.9 KB) 4.jpg
5.jpg (86.6 KB) 5.jpg
3.jpg (106 KB) 3.jpg
2.jpg (103 KB) 2.jpg
1.jpg (117 KB) 1.jpg
8.jpg (127 KB) 8.jpg

RE: Pas d'audio lors des appels sortants tant que l'appel n'a pas été placé en attente. - Added by Greg De_ 3 months ago

Et voici la sortie via le CLI de ma configuration SIP :

xivo*CLI> sip show settings

Global Settings:

UDP Bindaddress: 0.0.0.0:5060
TCP SIP Bindaddress: 0.0.0.0:5060
TLS SIP Bindaddress: Disabled
RTP Bindaddress: Disabled
Videosupport: No
Textsupport: No
Ignore SDP sess. ver.: No
AutoCreate Peer: Persisted
AutoCreate Context: xivo-initconfig
Match Auth Username: No
Allow unknown access: No
Allow subscriptions: Yes
Allow overlap dialing: Yes
Allow promisc. redir: No
Enable call counters: No
SIP domain support: No
Path support : No
Realm. auth: No
Our auth realm xivo
Use domains as realms: No
Call to non-local dom.: Yes
URI user is phone no: No
Always auth rejects: No
Direct RTP setup: No
User Agent: XiVO PBX 2020.07.05
SDP Session Name: Asterisk PBX 8:16.9.0-1~xivo2+deb9+20200630.134339.7c36a81
SDP Owner Name: root
Reg. context: (not set)
Regexten on Qualify: No
Trust RPID: Yes
Send RPID: Yes
Legacy userfield parse: No
Send Diversion: Yes
Caller ID: xivo
From: Domain:

Record SIP history: Off
Auth. Failure Events: Off
T.38 support: No
T.38 EC mode: Unknown
T.38 MaxDtgrm: 4294967295
SIP realtime: Disabled
Qualify Freq : 60000 ms
Q.850 Reason header: No
Store SIP_CAUSE: No

Network QoS Settings:

IP ToS SIP: CS0
IP ToS RTP audio: CS0
IP ToS RTP video: CS0
IP ToS RTP text: CS0
802.1p CoS SIP: 4
802.1p CoS RTP audio: 5
802.1p CoS RTP video: 6
802.1p CoS RTP text: 5
Jitterbuffer enabled: No

Network Settings:

SIP address remapping: Enabled using externaddr
Externhost:
Externaddr: MON_IP_PUBLIQUE:0
Externrefresh: 10
Localnet: 192.168.50.0/255.255.255.0

Global Signalling Settings:

Codecs: (alaw|g722|g729|h264|gsm|g723|ulaw)
Relax DTMF: No
RFC2833 Compensation: No
Symmetric RTP: No
Compact SIP headers: No
RTP Keepalive: 15
RTP Timeout: 0 (Disabled)
RTP Hold Timeout: 0 (Disabled)
MWI NOTIFY mime type: application/simple-message-summary
DNS SRV lookup: No
Pedantic SIP support: No
Reg. min duration 60 secs
Reg. max duration: 3600 secs
Reg. default duration: 120 secs
Sub. min duration 60 secs
Sub. max duration: 3600 secs
Outbound reg. timeout: 20 secs
Outbound reg. attempts: 0
Outbound reg. retry 403:No
Notify ringing state: Yes
Include CID: No
Notify hold state: No
SIP Transfer mode: open
Max Call Bitrate: 384 kbps
Auto-Framing: Yes
Outb. proxy:
Session Timers: Accept
Session Refresher: uas
Session Expires: 600 secs
Session Min-SE: 90 secs
Timer T1: 500
Timer T1 minimum: 500
Timer B: 32000
No premature media: Yes
Max forwards: 70

Default Settings:

Allowed transports: UDP
Outbound transport: UDP
Context: default
Record on feature: automon
Record off feature: automon
Force rport: No
DTMF: info
Qualify: 0
Keepalive: 0
Use ClientCode: No
Progress inband: Never
Language: fr_FR
Tone zone:
MOH Interpret: default
MOH Suggest:

Voice Mail Extension: *98
RTCP Multiplexing: No

    (1-7/7)
    Add picture from clipboard (Maximum size: 147 MB)