Fax to mail not working!

Added by Albert Saab over 2 years ago

It is a new XIVO installation.

We are getting this error when we try to send or receive a fax:
WARNING[24794][C-0000003a]: res_fax.c:2513 sendfax_t38_init: Audio FAX not allowed on channel 'Local/XXXXXXX@default-0000000b;1' and T.38 negotiation failed; aborting.

Same SIP gateway is used on another xivo installation and it is working fine.

Please advise.

Replies (1)

RE: Fax to mail not working! - Added by Laurent MEILLER over 2 years ago

Hi Albert,

It seems that Asterisk might allow you to have audio fallback :

Basically to enable it :

  • Connect to your XiVO
  • Edit /usr/share/xivo-config/dialplan/asterisk/extensions_lib_subr.conf and modify l.55 to be :
same  =   n,ReceiveFax(${XIVO_FAXFILE}, f)
  • launch asterisk cmd line (asterisk -r)
  • type dialplan reload
  • type dialplan show rxfax to check that modification is applied
  • retest