Project

General

Profile

Xivo et alcatel4018ee

Added by Alexis Fau over 2 years ago

Bonjour ,

J'ai une machine virtuelle sous debian avec xivo d'installé dessus , j'aimerais installer un poste alcatel 4018ee dessus , j'ai installé le plugin 'xivo-alcatel-2.01.10' , là où je bloque c'est au niveau de la config sur le poste , quand je me met en dynamic il ne trouve pas de serveur tftp , en static pareil , quand je passe de NOE à SIP j'ai un message comme quoi les fichiers de configuration sont manquants .

Comment faire ?

Merci d'avance


Replies (13)

RE: Xivo et alcatel4018ee - Added by Grégory Esnaud over 2 years ago

Bonjour,

Pourriez vous communiquer les fichiers de logs suivants lorsque la terminaison (ie votre alcatel) démarre:

  • tailf /var/log/xivo-provd.log

Merci

RE: Xivo et alcatel4018ee - Added by Alexis Fau over 2 years ago

Bonjour,

Tout d'abord merci pour votre réponse,

Excusez-moi pour le retard , j'ai fait un screen de ce que vous m'avez demandé.

Je pense plus que le problème viens de la config du poste.

Cordiament

xivo2.PNG (79.2 KB) xivo2.PNG
xivo.PNG (33.7 KB) xivo.PNG

RE: Xivo et alcatel4018ee - Added by jean-baptiste marin over 2 years ago

Bonjour,

dans le fichier de log (/var/log/xivo-provd.log), vous devriez avoir une requête du poste pour se provisionner mais elle n'apparaît pas.
Est-ce que le serveur XIVO attribue une IP à votre poste via son serveur de DHCP ?

RE: Xivo et alcatel4018ee - Added by Alexis Fau over 2 years ago

Bonjour,

Xivo est sur une machine virtuelle sur mon pc (avec hyperv), j'ai bien coché les cases du dhcp sur xivo et dans la rubrique 'Greffon' , le poste s'attribue bien une ip sur la livebox (192.168.1.56) mais je ne suis pas certain qu'il s'attribue une adresse ip sur xivo.

Comment le vérifier ?

Cordialement

RE: Xivo et alcatel4018ee - Added by Alexis Fau over 2 years ago

Bonjour , après quelques recherches , je pense que le problème viens de la livebox , j'ai donc installé pfsense sur une machine qui à plusieurs cartes reseaux et connecté le poste 4018 sur le lan de pfsense ainsi qu'un autre pc pour vérifier si tout fonctionne , le pc à bien de l'accès internet et ping bien la machine xivo , le téléphone s'attribue bien une ip , j'ai ajouté Xivo comme serveur dhcp supplémentaire dans pfsense , mais j'ai le message "No TFTP response" qui apparait sur le poste et le poste redémarre au bouts de quelques secondes , il n'apparait toujours pas dans la liste des terminaisons.

Comment faire ?

Cordialement

RE: Xivo et alcatel4018ee - Added by Grégory Esnaud over 2 years ago

Bonjour,

Pour résumer:

Nous sommes bien sur le schéma ci-joint?

https://framadrop.org/r/C6kxWxRSCg#RdrOfrfUUArbIcv6Sw7cz8o9lvwcSVJJXsUD65dWYls=

Pouvez vous nous repréciser:

  1. Le pfSense fait il serveur DHCP? En effet, vous parlez d'avoir "ajouté le XiVO comme DHCP supplémentaire"... cela laisse entendre qu'il y a au moins 2 serveurs DHCP.
  2. Si le pfSense fait serveur DHCP, avez vous bien renseigné les options TFTP dans les paramètres du serveur DHCP? Généralement il s'agit de l'option 66, à faire pointer vers l'ip du XiVO: http://enterprise.alcatel-lucent.com/assets/documents/SIP_End_point_4008EE_4018EE_EN_InstallationGuide-ed02.pdf
  3. Enfin, dans le screenshot que vous avez fourni, il semble que le poste cherche le greffon gigaset-c90... N'y a t'il pas une erreur quelque part, puisque l'on parle d'Alcatel 4018?

Merci!
Gregory

RE: Xivo et alcatel4018ee - Added by Alexis Fau over 2 years ago

Bonjour ,

Merci pour votre réponse , je confirme pour le schéma .

Pour répondre à vos questions :

  1. Oui le pfSense fait serveur DHCP , je me suis inspiré de cette article http://retroplace.nyxd.org/2015/03/24/xivo-sccp-et-provisioning-sur-telephones-non-supportes-et-dhcp-desactive/ pour essayer de faire avancer la situation , c'est sur ce blog que j'ai vu qu'il fallait ajouté Xivo en serveur dhcp additionel.

2- Non je n'avait pas renseigné d'options TFTP dans les paramètres de Pfsense

3- Pour le greffon , j'avais installé le gigaset-c90 pour faire des essais mais je l'ai désinstallé récemment pour éviter les conflits avec le plugin alcatel , maintenant il ne reste plus que le greffon alcatel 4018 installé sur mon xivo.

Je viens de refaire le test en faisant pointer l'option 66 sur xivo et le poste m'indique maintenant "bad TFTP1 Adress" et redemarre , j'ai vérifié dans les paramètres du poste , le poste s'attribue bien une ip dans la bonne plage , l'adresse du routeur est bien celle de pfsense. J'ai fait une capture d'écran de la config de pfsense et j'ai refait une capture des logs :

xivoca.PNG (63.2 KB) xivoca.PNG
xivo.PNG (37.6 KB) xivo.PNG

RE: Xivo et alcatel4018ee - Added by Grégory Esnaud over 2 years ago

Ok, ,je pense donc que nous avons un souci dans la conf DHCP du pfSense.
Si le service DHCP n'est pas nécessaire sur le pfSense :

  1. Activer le DHCP sur le Xivo et suivre cette doc: https://documentation.xivo.solutions/en/stable/xivo/system/dhcp/dhcp.html?highlight=dhcp#configuring-dhcp-server-for-other-subnets
  2. Désactiver le DHCP sur le pfSense
  3. Activer le DHCP relay sur le pfSense (https://doc.pfsense.org/index.php/DHCP_Relay) pour le faire pointer sur l'ip voix du XiVO.

Bpon courage,

RE: Xivo et alcatel4018ee - Added by Alexis Fau over 2 years ago

Bonjour,

J'ai suivi toutes vos instructions mais le poste ne parvient pas à s'attribuer une ip .

Que dois-je faire ?

RE: Xivo et alcatel4018ee - Added by Grégory Esnaud over 2 years ago

Bonjour,

Voyez vous des logs dans pfSense et dans xivo (/var/log/syslog) sur les requêtes DHCP?

cordialement,

RE: Xivo et alcatel4018ee - Added by jean-baptiste marin over 2 years ago

Bonjour,

dans la téléphonie sur IP en général, on sépare les flux DATA des flux VOIP.
Pour cela il faut un réseau distinct pour ces deux flux.
Il faudrait idéalement que votre téléphone soit sur un réseau (VLAN) ou seul est le XIVO (il est possible d'attribuer plusieurs interface réseau au XIVO).
L'interface servant à donner les IP doit être définie en "VOIX" et le serveur DHCP doit être activé. Seul ce serveur attribue les options de téléchargement aux téléphones lors de leurs boots.

Dans l'interface Web de XiVO, dans service -> ipbx -> terminaison, voyez-vous votre téléphone avec votre IP/MAC MARQUE/MODELE ? Tant que vous ne le verrez pas dans ce menu, c'est que le téléphone ne se voit pas attribuer une IP par le XIVO.

Cordialement

RE: Xivo et alcatel4018ee - Added by Alexis Fau over 2 years ago

Bonjour ,

Je vais essayer de créer un vlan voix pour xivo , pour répondre à votre question , non le poste n'apparait pas dans terminaison de xivo

RE: Xivo et alcatel4018ee - Added by Alexis Fau over 2 years ago

Bonjour ,

J'ai refait des tests avec vlan et le poste ne parvient pas à s'attribuer une iP et redémarre sans cesse . Je pense que le problème vient de pfsense , j'ai donc reconnecté Xivo et le poste à ma livebox , en dynamique le poste s'attribue bien une iP mais j'ai le message no tftp1 car le poste prenait en serveur tftp la livebox , je suis donc passé en fixe avec les mêmes paramètres iP , le poste apparaît bien sûr l'interface de la livebox et j'ai changé le tftp par l'adresse de xivo , maintenant j'ai le message "file not found"

Comment faire pour que je poste s'approvisionne ?

N'est il pas possible de passer le poste en sip manuellement en installant le firmware adéquate ?

Cordialement

    (1-13/13)