Project

General

Profile

les agents se déconnectent tout seuls

Added by Ced S almost 3 years ago

Bonjour,

content de retrouver le forum que je cherchais depuis un bout de temps depuis le changement de domaine !
en espérant que vous avez passé de bonnes fêtes !

j'ai ici une file xivo avec qq agents dessus. Ils se connectent/déconnectent suivant leur dispo en utilisant une touche du téléphone.
Le pb est que parfois, alors que la touche est toujours rouge la personne n'est en fait plus connectée, donc sans qu'elle le sache.
Elle s'en rend compte en appuyant "juste pour voir" sur la touche de log.
Je l'ai pour plusieurs personnes, c'est un peu aléatoire (car au début je pensais à un timeout)

Une idée du pourquoi ? Quelles infos je pourrais regarder ou vous donner en plus ?

Merci


Replies (12)

RE: les agents se déconnectent tout seuls - Added by Grégory Esnaud almost 3 years ago

Bonjour,

Les agents utilisent ils, en plus de la touche du téléphone, le xivo client "lourd"?

Merci,

RE: les agents se déconnectent tout seuls - Added by Ced S almost 3 years ago

Oui.
Au début ils l'utilisaient en profil "client" car plus utile pour eux. J'en ai mis un pour surveiller, en profil "agent" et ça change rien. Par contre le client, voit bien qu'il est déconnecté...

Pour être plus précis : quand elle sait qu'elle est déconnectée (car les appels finissent ailleurs) elle appuie sur la touche du téléphone (qui est pourtant toujours rouge) et ça dit "vous êtes maintenant connecté" et ça reste rouge... et ça remarche un certains temps.

Merci d'avoir répondu entre deux fêtes :)

RE: les agents se déconnectent tout seuls - Added by jean-baptiste marin almost 3 years ago

Bonjour,

est-ce qu'il arrive à vos agents de se mettre en "parti manger" "ne pas déranger" ou autre depuis le XIVO CLient ?
utilisent-il le profil agent? si oui, quand ils se connectent, est-ce qu'il renseigner l'option "agent loggé" avec leur numéro de poste?

Cordialement

RE: les agents se déconnectent tout seuls - Added by Ced S almost 3 years ago

Bonjour Jean-Baptiste,

Non aucun changement dans la journée, les agents restent normalement loggués sans rien toucher
Au début ils étaient en profil client (car pas besoin du cleint en mode agent), là je viens de mettre la personne en profil agent et je l'ai logué dans le client xivo en mettant agent loggé et numéro de poste comme tu me dis.
Je te dis ce que ça donne.

Merci et bonne année à toi et tous les contributeurs!

RE: les agents se déconnectent tout seuls - Added by Ced S almost 3 years ago

Bonjour,

qqun a une idée ?
Car je sais pas quoi faire

Merci

RE: les agents se déconnectent tout seuls - Added by Ced S almost 3 years ago

J'ai juste oublié de préciser dessus : le fait de se loguer avec le numéro ne change rien

RE: les agents se déconnectent tout seuls - Added by Ced S almost 3 years ago

Bonjour,

personne n'a d'idée ?
Ma collègue se désespère, ce matin plusieurs deco.

Merci

RE: les agents se déconnectent tout seuls - Added by Anonymous almost 3 years ago

Bonjour,

Tu as regardé si il y a des choses dans : /var/log/xivo-agentd.log ?

RE: les agents se déconnectent tout seuls - Added by Etienne Allovon almost 3 years ago

Pour compléter :
Une source possible du problème est l'utilisation simultanée d'une touche sur le téléphone et du XiVO Client en mode agent.

Il n'y a pas de synchronisation entre l'état de la touche du téléphone et les actions sur le XiVO Client.

Par exemple :

  1. je me loggue avec la touche, -> la LED est allumée et je suis loggué
  2. je me loggue sur mon xivo client en mettant "Agent déloggué" -> la LED est toujours allumée (pas de synchro), mais mon agent est déloggué

RE: les agents se déconnectent tout seuls - Added by Ced S almost 3 years ago

Benoît > non, il va falloir que je regarde, merci de l'idée

Etienne > elle ne le fait qu'à la touche téléphone, son client n'est pas toujours lancé, de plus il n'est pas en mode agent

Merci à tous les deux

RE: les agents se déconnectent tout seuls - Added by Ced S almost 3 years ago

Bon, comme un fait exprès depuis que je sais que je peux aller voir dans les logs, plus de pb !
Donc j'attend un crash future pour dire ce que j'ai dans les logs.

Merci de votre patience :)

RE: les agents se déconnectent tout seuls - Added by Dominique GOUDIN over 2 years ago

Bonjour,

J'ai le même pb. Parfois quand un agent pense se déconnecter, il se connecte, ou l'inverse. L'état du voyant de la touche n'est pas toujours représentatif.

Config : XIVO - Version : 16.08.2 "Five" + postes Snom D275

Dominique

    (1-12/12)