Projet

Général

Profil

Erreur lors de l'install d'un greffon

Ajouté par Ced S il y a 3 mois

Bonjour,

c'est sur une install un peu ancienne (15.10 "five")
Si je clique sur la "plabète" pour les màj de greffon il m'annonce une erreur (sans rien dire de plus) et idem si j’essaie de mettre à jour un greffon.
J'avais déjà eu le pb et à l'époque c'est un pb de DNS, là il semble OK
Ce qui est bizarre c'est que je n'ai rien dans /var.log/daemon.log

Un idée ?

Merci


Réponses (10)

RE: Erreur lors de l'install d'un greffon - Ajouté par Alexandre SEMONSUT il y a 3 mois

Bonjour, quelle est l'adresse du miroir de téléchargement ? (à voir dans Configuration / Approvisionnement / Général.

Cordialement

RE: Erreur lors de l'install d'un greffon - Ajouté par Ced S il y a 3 mois

Merci pour la piste !
Sur ce xivo j'ai http://provd.xivo.io/plugins/1/addons/stable/
Sur d'autres http://provd.xivo.io/plugins/1/stable/

J'ai donc changé l'un par l'autre mais ça n'est pas mieux.
Une idée ?

Merci

RE: Erreur lors de l'install d'un greffon - Ajouté par Ced S il y a 3 mois

En fait qqchose a dû changer, car même sur une infra où je suis sur que ça fonctionnait, ça ne fonctionne plus...

Merci de votre aide

RE: Erreur lors de l'install d'un greffon - Ajouté par Enzo PICCOLINO il y a 3 mois

Bonjour,

peux tu essayer de passer cette procédure ?
https://documentation.xivo.solutions/en/latest/installation/xivo/upgrade/switch_xivosolutions.html?highlight=switch

Ensuite l'adresse des dépôts n'est plus valide (injoignable depuis un navigateur par exemple)
La bonne adresse est : http://provd.xivo.solutions/plugins/1/stable/

Bonne soirée,

RE: Erreur lors de l'install d'un greffon - Ajouté par Ced S il y a 3 mois

Merci beaucoup de la réponse!

J'ai fait la manip au complet du lien que tu m'as donné.
J'ai 8.8.8.8 en dns pour être sûr
Du xivo, je résout bien le provd.xivo.solutions
Dans l'appro maintenant j'ai http://provd.xivo.solutions/plugins/1/stable/

Dans appro/greffons, je clique sur la planète en haut à droite et ça a bien mis à jour la liste.
Pour autant ça ne veut toujours pas ajouter le module cisco spa525
J'ai donc cliqué sur la màj proposée du module, ça s'est fait sans soucis
Mais si je vais dedans pour ajouter le module spa525 j'ai l'erreur : xivo-cisco-spa-7.5.5 a rencontré une erreur durant l'installation

Et je ne vois rien dans /var/log/daemon

Décidément ça veut pas !
Une autre idée ? Merci

RE: Erreur lors de l'install d'un greffon - Ajouté par Alexandre SEMONSUT il y a 3 mois

il faut regarder dans /var/log/xivo-prod.log

RE: Erreur lors de l'install d'un greffon - Ajouté par Ced S il y a 3 mois

Merci, je vois plus de choses
Il y a bien une erreur, ça parle à qqun ?

2018-09-24 17:32:54,415 2988 (twisted): 127.0.0.1 - - [24/Sep/2018:15:32:53 +0000] "GET /provd/pg_mgr/plugins/xivo-cisco-spa-7.5.5/info HTTP/1.1" 200 615 "-" "-"
2018-09-24 17:32:54,421 2988 (twisted): 127.0.0.1 - - [24/Sep/2018:15:32:53 +0000] "GET /provd/pg_mgr/plugins/xivo-cisco-spa-7.5.5/install/installable HTTP/1.1" 200 514 "-" "-"
2018-09-24 17:32:54,428 2988 (twisted): 127.0.0.1 - - [24/Sep/2018:15:32:53 +0000] "GET /provd/pg_mgr/plugins/xivo-cisco-spa-7.5.5/install/installed HTTP/1.1" 200 159 "-" "-"
2018-09-24 17:32:54,433 2988 (twisted): 127.0.0.1 - - [24/Sep/2018:15:32:53 +0000] "GET /provd/pg_mgr/plugins/xivo-cisco-spa-7.5.5/configure HTTP/1.1" 404 153 "-" "-"
2018-09-24 17:32:59,194 2988 (provd.plugins): Installing plugin-package spa525-fw
2018-09-24 17:32:59,195 2988 (twisted): 127.0.0.1 - - [24/Sep/2018:15:32:58 +0000] "POST /provd/pg_mgr/plugins/xivo-cisco-spa-7.5.5/install/install HTTP/1.1" 201 - "-" "-"
2018-09-24 17:33:00,391 2988 (twisted): 127.0.0.1 - - [24/Sep/2018:15:32:59 +0000] "GET /provd/pg_mgr/plugins/xivo-cisco-spa-7.5.5/install/install/5 HTTP/1.1" 200 90 "-" "-"
2018-09-24 17:33:01,389 2988 (twisted): 127.0.0.1 - - [24/Sep/2018:15:33:00 +0000] "GET /provd/pg_mgr/plugins/xivo-cisco-spa-7.5.5/install/install/5 HTTP/1.1" 200 90 "-" "-"
2018-09-24 17:33:02,403 2988 (twisted): 127.0.0.1 - - [24/Sep/2018:15:33:01 +0000] "GET /provd/pg_mgr/plugins/xivo-cisco-spa-7.5.5/install/install/5 HTTP/1.1" 200 90 "-" "-"
2018-09-24 17:33:02,851 2988 (xivo_fetchfw.download): HTTPError while downloading 'cisco:flowid=5301,mdfid=282414147,softwareid=282463651,release=7.5.5': HTTP Error 503: Service Unavailable
2018-09-24 17:33:02,853 2988 (provd.plugins): Error while installating plugin-package spa525-fw: HTTP Error 503: Service Unavailable

2018-09-24 17:33:03,387 2988 (twisted): 127.0.0.1 - - [24/Sep/2018:15:33:02 +0000] "GET /provd/pg_mgr/plugins/xivo-cisco-spa-7.5.5/install/install/5 HTTP/1.1" 200 75 "-" "-"
2018-09-24 17:33:03,393 2988 (twisted): 127.0.0.1 - - [24/Sep/2018:15:33:02 +0000] "DELETE /provd/pg_mgr/plugins/xivo-cisco-spa-7.5.5/install/install/5 HTTP/1.1" 204 - "-" "-"
2018-09-24 17:33:04,595 2988 (twisted): 127.0.0.1 - - [24/Sep/2018:15:33:04 +0000] "GET /provd/pg_mgr/plugins/xivo-cisco-spa-7.5.5/install/install/5 HTTP/1.1" 404 153 "-" "-"
2018-09-24 17:33:04,813 2988 (twisted): 127.0.0.1 - - [24/Sep/2018:15:33:04 +0000] "GET /provd/pg_mgr/plugins/xivo-cisco-spa-7.5.5/info HTTP/1.1" 200 615 "-" "-"
2018-09-24 17:33:04,819 2988 (twisted): 127.0.0.1 - - [24/Sep/2018:15:33:04 +0000] "GET /provd/pg_mgr/plugins/xivo-cisco-spa-7.5.5/install/installable HTTP/1.1" 200 514 "-" "-"
2018-09-24 17:33:04,826 2988 (twisted): 127.0.0.1 - - [24/Sep/2018:15:33:04 +0000] "GET /provd/pg_mgr/plugins/xivo-cisco-spa-7.5.5/install/installed HTTP/1.1" 200 159 "-" "-"
2018-09-24 17:33:04,832 2988 (twisted): 127.0.0.1 - - [24/Sep/2018:15:33:04 +0000] "GET /provd/pg_mgr/plugins/xivo-cisco-spa-7.5.5/configure HTTP/1.1" 404 153 "-" "-"
2018-09-24 17:33:06,316 2988 (twisted): 127.0.0.1 - - [24/Sep/2018:15:33:05 +0000] "GET /provd/pg_mgr/plugins/xivo-cisco-spa-7.5.5/install/install/5 HTTP/1.1" 404 153 "-" "-"
2018-09-24 17:33:06,610 2988 (twisted): 127.0.0.1 - - [24/Sep/2018:15:33:06 +0000] "GET /provd/pg_mgr/plugins/xivo-cisco-spa-7.5.5/install/install/5 HTTP/1.1" 404 153 "-" "-"
root@xivo-gipsi:~#

RE: Erreur lors de l'install d'un greffon - Ajouté par Enzo PICCOLINO il y a 3 mois

Bonjour,

oui ça me parle mais pour SPA 8000. Cisco a changer ses installateurs de place. Du coup on essaie de chercher un lien qui n'existe plus (version simple)

du coup il faut télécharger le firmware manuellement sur leur site et le mettre dans le bon répertoire du xivo

Copy the firmware (.zip) in /var/lib/xivo-provd/plugins/xivo-cisco-spaXXXXX/var/cache
Unzip it
If necessary, create the folder firmware (mkdir /var/lib/xivo-provd/plugins/xivo-cisco-spaXXXXXXXX1/var/tftpboot/firmware)
Movethe .bin file in the previous folder (mv spa8000-6-1-11.bin /var/lib/xivo-provd/plugins/xivo-cisco-spaXXXXXXXX/var/tftpboot/firmware/)
Change the owner of the file (chown -R xivo-provd:xivo-provd var/lib/xivo-provd/plugins/xivo-cisco-spaXXXXXXXX/var/tftpboot/firmware/)

Bonne chance,

RE: Erreur lors de l'install d'un greffon - Ajouté par Ced S il y a 29 jours

Enzo,

merci de cette réponse détaillée et désolé de ma réponse tardive.

J'ai un site avec les mémes versions sur lequel il y a un spa525G.
J'ai donc copié le fichier bin de l'un vers l'autre.

Si je vais dans l'interface/greffons il ne me le voit pas comme un greffon installé, mais c'est peut-être normal ?
Je vais faire brancher le téléphone pour voir.

Le chown me dit utilisateur incorrect, mais j'ai comparé les droits de chaques coté et ils sont parails, et c'est root le owner a priori.

Merci !

RE: Erreur lors de l'install d'un greffon - Ajouté par Ced S il y a 29 jours

Bon, si je vais sur la terminaison dans la liste des greffons, j'ai pas le nouveau
j'ai bien fait un "service xivo-provd restart" mais pas mieux

Il doit falloir l'ajouter dans une liste j'imagine...

    (1-10/10)